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1 Software
7KH� VRIWZDUH� VXSSOiHG� ZiWK� WKH� 5iFKWHU� 2SWiFD� 8�'�� 8;��'�� 8�'�� 6�'� DnG� 6�'�

GigiWDO� PiFURVFRSHV provides functions to fully control the camera and YiHZ�OiYH�iPDgHV�

IURP�WKH�PiFURVFRSH.�8VH the videostream processed by WKH�Ultra FineTM color engine at

high speed, which includes D�dedicated pipeline to process the raw data into FUiVS�iPDgHV.

$�YDUiHW\�RI�XVHIXO�WRROV are provided for specific purposeV, such as luminance calibration,

measurement, image stitching, extending depth of field, video watermark attachment, color 

composition, DnG�imaging processing. 6HOHFW�IURP�D�YDUiHW\�RI�ODngXDgHV. 7KiV�VRIWZDUH�ZDV�

GHVignHG�ZiWK�ERWK�WKH�PHGiFDO�IiHOG�DV�ZHOO�DV�WKH�inGXVWUiDO�TXDOiW\�FRnWURO�DnG�

PDnXIDFWXUing�inGXVWUiHV�in�PinG.�7KiV�VRIWZDUH�iV�FRPSDWiEOH�ZiWK�WKH�5iFKWHU�2SWiFD�GigiWDO�

PiFURVFRSHV.�

1.1 Operating System 

Microsoft Windows:

 32bit Windows XP, Vista, 2008, Win7, Win8

 64bit Windows XP, Vista, 2008, Win7, Win8

Mac:

 OS X 10.6,OS X 10.7,OS X 10.8

Linux:

 Linux 2.6 or above

1.2 Supported LanguageV

Standard Language Package:

z (ngOiVK�Simplified Chinese�Traditional Chinese

Optional Language PackageV:

z German� Japanese� Russian� French� Italian��Polish� Turkish
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2 Start to Use the Software

2.1 Start Software

1. Install ToupTekToupViewSetup.exe to finish the installation.

2. Double click on the desktop icon  to start the Software.

Note: If you are using the Windows 64-bit system, it is recommended to select the x64 ToupView to run the 

Software with maximum performance, even though x86 ToupView could also work.

2.2 Open the Camera 

The software will detect all of the cameras that your computer has installed (Here, it is UCMOS03100KPA,

a 3.1M pixel CMOS camera) and will append all the camera names as submenu to the File>Camera List menu 

(Here, the submenu name is “UCMOS03100KPA”). 

Choosing the File>Camera List>UCMOS03100KPA will create a video window and start the video stream. 

The video window will be associated with the name of “Video [UCMOS03100KPA]” (i.e., its title bar name will 

be “Video [UCMOS03100KPA]”). 

There are 4 methods to start the video stream, they are: 

File>Camera List  Choose the File>Camera List>UCMOS03100KPA (Here, a 3.1M pixel camera is installed)

command to create the video window

Camera Sidebar  Click the Camera Sidebar (If it is not activated) and the Camera List to expand the Camera List

group (if not expanded). Click the camera name (Here it is UCMOS03100KPA) to create the video

Toolbar button  Click the button ’s down arrow on the toolbar to expand the camera list and choose the right 

camera (Here it is UCMOS03100KPA) to create the video window.

Twain Acquire  Choose the File>Twain: Select Device••• command to select the device UHCCD01400KPA from

the Select Source dialog (If never selected before)

 Choose the File>Twain: Acquire••• command. There should be a dialog box similar to below.

Note: The Software supports the connection of one or more cameras to the computer at a time.
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2.3 Adjust Settings of the Camera 

2.3.1 Change the Resolution Setting 

Control 

Group 

Function 

 Snap : Click to snap images with specified resolution 

 Record : Click to start to record video 

 Live: Set the Video resolution for preview

 Snap: Set the Snap resolution for capture

Remarks 

 Live: Select a resolution and videostream will be generated in the specified resolution continuously.

Generally a small resolution is selected to obtain faster Video Frame Rate.

 Snap: Select a resolution and an image in the specified resolution will be obtained when clicking on the

Snap button. Generally the maximum resolution is selected for high quality.

2.3.2 Change the Exposure Time and Gain Setting 

Control 

Group 

Function 

 When the Exposure & Gain group is expanded，a green rectangle viewfinder marked with Exposure

will be overlaid on the Video. This labeled region is taken as the reference region for judging if the

average brightness in the region has reached the Exposure Target value. The Exposure ROI rectangle

border can be dragged to modify the size.

 Uncheck the Auto Exposure box to switch the the exposure control from Auto Exposure mode to

Manual Exposure mode. The Exposure Target slider will be disabled and the Exposure Time slider bar

will be enabled for adjustment. Increasing the Exposure Time will increase the brightness and

decreasing it will do the opposite. Increasing the Exposure Time has no effect on the frame rate until it

reaches a specific limit. If the Exposure Time is larger than the limit, the frame rate will be decreased.

 In the Manual Exposure mode at a fixed Exposure Time, the image brightness can also be changed by

adjusting the microscope light source.

 Increasing the Gain can also increase the brightness without having an effect on the frame rate. But

Gain with a greater value will also magnify the noise. So only when the microscope light intensity is
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very weak, drag the Gain slider right to obtain a brighter scene.

Remarks 

 The primary user can choose Automatic Exposure mode, by setting the appropriate Exposure

Target value, to make the image brightness comfortable for the human eye. When the external light

source intensity is changed, the software will adjust the Exposure Time automatically to match

the average brightness in the viewfinder area to the target brightness.

 The other option is that the user can uncheck the Auto Exposure and adjust the Exposure Time

manually by dragging Exposure Time slider.

2.3.3 Change the White Balance Setting 

Control 

Group 

Function 

 Expand the White Balance group and a red rectangular viewfinder marked with White Balance will be

overlaid on the video; Drag the viewfinder to a pure white or gray object and click White Balance

button to establish the video white balance for future video.

 Temperature and Tint could be used to adjust White Balance setting manually for user defined

purpose.

Remarks 

 It is recommended that the temperature value be set to a color temperature value of the light source

to obtain a proper white balance effect.

 Users could adjust Temperature and Tint value to obtain a particular effect. For example, setting a

lower temperature will have a warmer effect on the video.

2.3.4 Change the Color Setting 

Control 

Group 

Function 

 Hue: Adjust the Hue value of the video

 Saturation: Adjust the saturation value of the video

 Brightness: Adjust the brightness value of the video
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 Contrast: Adjust the contrast value of the video

 Gamma: Adjust the gamma value of the video

 Defaults: Restore all the color settings to default one

Remarks 

 Contrast and Gamma adjustment can bring sharper or brighter effects in some conditions.

2.3.5 Change the Frame Rate Setting 

Control 

Group 

Function 

 This group can be used to adjust the Video Frame Rate. Drag the slider to the right to ensure the fatest

Video Frame Rate if your computer USB hub supports this.

Remarks 

 If the Video window appears black and fails to display, drag the slider to the left one step a time until

the video window displays video normally. This condition occurs when the USB transportation

capability of the hardware on the PC side is not strong enough.

2.3.6 Change the Color mode Setting 

Control 

Group 

Function 

 Color: Set the video to Color mode

 Gray: Set the video to Gray mode

Remarks  Gray images can be used in applications without color requirement

2.3.7 Change the Flip Setting 

Control 

Group 

Function 

 Horizontal: If the Video on the screen appears in a different horizontal direction, check this box to

set the video direction to the correct alignment.

 Vertical: If the Video on the screen appears in a different vertical direction, check this box to set the

video direction to the correct alignment.

Remarks 

 If the video has an orientation deviation of 90 or 270 degrees, please rotate the camera relative to

the sample to adjust the video orientation.
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2.3.8 Change the Sample Mod Setting 

Control 

Group 

Function 

 Bin: Pixel binning refers to the method of combining (averaging) adjacent pixels of the same color.

Since Bin will take some time, the frame rate in Bin mode is normally slower than that in Skip mode.

 Skip: Also called Decimation, means that a certain amount of pixels is not read out but skipped

(horizontally, vertically or in both axes). This reduces resolution of the resulting image to obtain a

high frame rate with a side effect of introducing sub sampling artifacts.

Remarks 

 Bin: Good image quality, spends a little more time on calculation while the frame rate is reduced.

 Skip: Fast frame rate while the image quality is slightly lower.

2.3.9 Change the Power Frequency Setting 

Control 

Group 

Function 

 This function can eliminate the stroboscopic phenomenon between different countries and areas

for different power frequency, please select it according to your local power characteristics.

Remarks 

 The setting for USA is 60Hz.

 If the stroboscopic phenomenon still appears after choosing the right power frequency, please set

the Exposure Time to the integer times of 10ms(50Hz)/8.333ms(60Hz). This can eliminate

the stroboscopic phenomenon completely.

2.3.10 Change the Histogram Setting 

Control 

Group 

Function 

 A Histogram illustrates how pixels in an image are distributed in each color channel. A Histogram can

help you determine whether an image has enough detail to make a good correction.

 There are two lines on the right and left. The pixels will always be distributed between the two

lines. Repositioning the lines will change the distribution of the pixels.

Remarks 

 Dragging the left vertical line to the right will increase the image contrast while dragging the right

vertical line to left will will increase the image background brightness.
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2.3.11 Save & Load Parameter Setting 

Control 

Group 

Function 

 After the light source and the camera parameters are adjusted to make the video settings satisfactory, 

the camera control settings can be saved by clicking the Save button. The saved parameter can be 

Load(ed) for later use to resume the same scenario. 

Remarks  The parameters can also be saved, loaded, and overwritten. 

2.4 Image Capture and Save 

2.4.1 Single Frame Capture and Save 

Click the Snap button on the Camera Control Sidebar, and an image can be obtained in a specified resolution. 

Note: Using the ROI tool to select the region that you are interested in, the snapped image will capture only the 

ROI area. 

To save a current captured image, clicking the      Save button on the toolbar will bring up a dialog called 

Save as. Fill the content in the dialog and click Save to save the captured image. The software supports these 

formats: Window Bitmap(*.bmp ， *.dib ， *.rle) , JPEG(*.jpg， *.jpeg， *.jpe， *.jif ， *.jfif), Portable 

Network Graphics(*.png),Tag Image File Format(*.tif，*.tiff),Compuserve GIF (*.gif), PCX(*.pcx), 

Targa(*.tga), JBIG(*.jbg),ToupView File Type(*.tft).

Note: For Window Bitmap(*.bmp，*.dib，*.rle)，Compuserve GIF (*.gif)，PCX(*.pcx)，Targa(*.tga)， 

JBIG(*.jbg)，ToupView File Type(*.sft)，the Options button is not enabled to indicate that these formats do not 

have optional settings. 

For JPEG(*.jpg，*.jpeg，*.jpe，*.jif，*.jfif),  Portable Network Graphics(*.png), Tag Image File Format(*.tif， 

*.tiff), the Option button is enabled. The corresponding dialogs are shown  below (Fig.2~Fig.4): 

Fig.2 Fig.3 
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Fig.4 Fig.5 

Image quality  To save an image in JPEG format (*.jpg), Image quality can be adjusted in the edit box. 

The values range from 0 to 100. Default value = 75. 

Progressive  The default is unchecked

Optimize coding  The default is unchecked

Smoothing  The values range from 0 to 100. Default value = 0. 

Save these setting 

as defaults 

 When saving a file, the current settings will be saved as defaults for the next file save 

operation if this box is checked. 

Interlaced  The default is unchecked

Appended pages  Determine whether the current image will be saved in multiple page styles or not 

Compressions  TIFF format can be chosen in different compression formats, default value = LZW 

Image quality  If Compressions is chosen for JPEG, the Image quality is adjustable. The values range 

from 0 to 100. Default value = 75. 

Reset  Set to a specified value

Save these setting as default   The current settings will be saved as defaults for the future. 

2.4.2 Sequence Capture and Batch Save 

Choose Capture>Time>Lapse menu to set the Time-lapse(Auto Capture) parameter. (See Fig.1) 

Fig.1 
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Sequence capture is also called Time-Lapse Capture. This command can capture a sequence of pictures in a 

predefined interval. The user can specify the directory and naming format for the captured images, precisely 

set the interval (Time slot from 2 to 3600 seconds) and the total number of images to be captured.  

When a lot of images are captured, the File>Batch Save… will be enabled. 

The captured files can be saved by choosing File>Batch Save… menu(Fig.5). 

2.5 Video Record 

Fig.6 Fig.7 

Clicking the Record button on the Camera control sidebar in the Capture & Resolution Group 

will bring up the Video Format dialog（Fig.6). Check the wmv/asf or avi and click Next to start the Video File 

dialog as shown in Fig.7. 

Fill the Video File Name and Directory, clicking Next will start the Encoder dialog (Fig.8). 

Here you can select the Encoder format, set the Bitrate(Kbps), Quality(1-100) and Key Frames Spacing 

(1-30), clicking Next will start the Display Information dialog(Fig.9).

Here you can enter Title, Author, Copyright and Description to their fields. Clicking Back to return to the 

Encoder dialog, or Next to move to the next step (Fig.10). 
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Fig.9 Fig.10 

A dialog called Start to Record will be brought up(Fig.10). Here you can check Time Limit (from 1 to 1440 

minutes), enter recording time (If checked) and Time-lapse (1-100). There is a Summary that displays all the 

options. Click Finish to start to record the video. 

After the Video Record is started. The Record button on the Camera Sidebar will become .

Clicking will stop the recording process.

2.6 Open the Browse Window

Choose the View>Browse menu from the View menu or click the Browse toolbar button to browse 

images under the specified directory on the Folders Sidebar;

Click the Folders Sidebar to activate it. Double-clicking the listed directory in the Folders Sidebar will

create a Browse window as shown below(Fig.11).

Fig.11

After creating the Browse window, the software will display the Browse window that looks similar to

windows explorer. The child window on the left part of the Browse window titled Folders Sidebar can be

used to relocate the directory on the hard disk.
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Images in the current directory can be displayed in Large Icons or Small Icons mode on the right side of the 

Browse window in the settings. 

When the Browse window is active, the Edit and View menus will be changed to the following styles. There 

are shown as below. 

The Edit menu(Fig.12) The View menu(Fig.13) 

These two menus can be used for setting the Browse window. For example, image file order can be set in Forward 

or Reverse format according to Sort by Name, Type, Size, Width or Height. 

2.7 Close Windows 

2.7.1 Close single Windows 

Click on the window top-left corner to close the corresponding or double-click the name of the window. 

2.7.2 Close All 

Choose Windows>Close All menu to close all of the open images or captured images inside the software frame. 
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3 Windows Graphic User Interface

3.1 Functions of the Interface

A:ToupView B: Menu   C:ToupView toolbar D:Camera Sidebar

E: Folders Sidebar F: Undo/Redo Sidebar G: Layer Sidebar

M:Vertical ruler

H: Measurement Sidebar I: Measurement Sheet J:Statusbar

K: Auto Hide button L: Horizontal ruler

N:Frame Rate O:Frames captured P:Current Video sizes

Menu
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Q: Selected microscope Magnification  R: Current Unit

AA: Sidebar right mouse button context menu

AB: Video window right mouse button context menu

AC: Browse window right mouse button context menu

AD: Image window right mouse button context menu

AE: Frame window right mouse button context menu  

AF: Double-click bring up Video Properties dialog  

AG: Double-click bring up Magnification dialog

AH: Double-click bring up Measurement dialog

AI: Horizontal Ruler or Vertical Ruler right mouse button context menu 

3.2 ToupView Toolbar 

Item Function Item Function 

1 Open ( Ctrl+O) 16 Parallel 

2 Save( Ctrl+S) 17 Two Parallel 

3 Browse(Ctrl+B) 18 Vertical 

4 Camera List 19 Rectangle 

5 Unit 20 RoundRect 

6 Magnification 21 Ellipse 

7 Zoom 22 Circle 

8 Video Source Properties 23 Annulus 

9 Video Stream Format 24 Two Circles 

10 Video/Image Select 25 Arc 

11 Track 26 Text 

12 Object Select 27 Polygon 

13 Angle 28 Calibration 

14 Point 29 Gray Calibration 

15 Line 30 Manual Fusion 
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4 Software Practial Tool Kit 

4.1 Luminance Calibration Tool 

Control 

Dialog 

Function 

 Switch the camera from the Auto Exposure mode to the Manual Exposure mode in the Exposure & 

Resolution group. 

 Use ROI Image Select button

 Click Gray Calibration button

to select a ROI on the background.

on the toolbar and the above dialog box appears.

 Adjust light source brightness to make the Average Gray value the desired value. 

Initial Set  Recommended Average Gray value = 190~205. 

4.2 Video or Image Calibration Tool 

Control 

Dialog 

Function 

Initial Set 

 Set the Live Resolution to the maximum resolution in the Capture & Resolution group.

 Set the Zoom ratio to 100%.

 Click the Calibration button on the toolbar.

 Drag the reticule to align the calibration tails.

 Input the objective lens Magnification, Actual Length of the calibration tails, and then click OK button to 

end the calibration.

 *The Export button is used to export the calibrations to a file. This will save the calibration parameters 

and can be Imported again for the future application.

 *Make sure to use the right Magnification calibration file to match the actual lens’ magnification. 
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4.3 Video Overlay Tool 

Control 

Dialog 

Function 

 Choose Setup>Video Overlay menu to overlay the current Magnification, Scale Bar, Date Time and 

Clarity Factor on the video. 

Initial Set 

 *The Overlays can be overlaid on the captured image by checking Capture with Marker and 

Watermarker box on the Options>Preferences>Capture dialog. 

4.4 Video or Image Measurement Tool 

Control 

Dialog 

Function 

 Measurement tool includes common two-dimensional plane measurement command. Choose suitable 

tool according to your specific application.

 Click the measure anchor and click the left button of the mouse to finish the measurement. Clicking the 

right button of the mouse will abort the current measurement. The Measurement Object can be moved, 

deleted or modified by selecting it with the Object Select tool.

 Choose the Export to Image in Layer menu to combine the Measurement Objects with the background 

image to form a new background image.

 All the measure anchors reside on a new layer over the background image and will not damage the 

original image. After the object is selected, click Delete on keyboard to delete them. 

Initial Set  The Object properties can be predifined by Options>Measurement>General or Object page. 



Software Practical Tool Kit 

16 

4.5 Extending Depth of Field (EDoF) Tool 

Control 

Group 

Function 

 Click Manual Fusion on the toolbar and click Capture to capture the image for Fuse operation. 

 Finely and evenly adjust the Z-Axis and capture image once for each adjustment. Click Manual Fusion 

after done capturing images. Wait for a while, and then a new EDoF image window will be created.

 This EDoF extracts the clearest part from the different focal planes to take the place of the fuzzy part to 

obtain a clear image. Please pay attention to the changes of every adjustment and make sure that each 

image has a different clear part. To avoid the misalignment, please don’t change the XY direction in the 

EDoF process. 

Initial Set 

 Make sure that each image has a different clear part. It is not necessary to capture too many images.

 Rotate the fine focus on the microscope evenly along the same direction in the EDoF process.

 Images without clear parts will make the final picture fuzzy. 

4.6 Video or Image Stitching Tool 

Control 

Dialog 

Function 

 Uncheck the Auto Exposure box to set the Exposure mode to Manual Exposure mode and make the

image clear.

app:ds:focal
app:ds:plane
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Initial Set 

 Choose Process>Stitching ( ) menu , click Snap to capture image and then move the sample forward 

along a direction, click Snap and click capture again to repeat the operations until the end. After all the 

images have been captured, Click OK to begin the image stitching process and after a while, a stitched

image will be generated in a new window.

 Make sure that the image brightness does not change significantly during the movement.

 *Each moving distance should not exceed 75% of window content, which means that there should be 

25% overlap region between every 2 adjacent images.

 Click Image Select button to select the desired area and click Image>Crop (Shortcut Key: Shift+C) to 

remove the ragged black edge (caused by the movement that is not in an extremely straight line). Finally, 

choose save to finish the image Stitching process.

4.7 ROI Image Select Tool

Control 

Dialog 

Function 

 Image Select button on the toolbar has many applications. 

 Select a region in the video window and click Snap to obtain a selected ROI image

 Select a region in the video window and click Gray Calibration tool to calibrate the video gray to a 

desired value for the Luminance calibration.

 Selecting a region in the video window will enable the Copy button.

Initial Set  *Click Image Select button to activate it and click again to close it.

4.8 Video or Image Grid Tool

Control 

Dialog 
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Function 

Initial Set 

 Operating method: Choose View>Ruler and Grid>Grids>Auto Grids menu.

 It can be used as a virtual cell counting chamber.

 *Auto Grids: The grid's density is changed according to the image resolution.

 *Manual Grids: Manually dragging the horizontal or vertical arrow at the top left of the window to a 

desired region will overlay a grid line on the image. 

4.9 Video Watermark Tool 

Control 

Dialog 

Function  See the detailed information in Setup>Watermark section in the Software help file 

Initial Set 

 The watermark file format must be 24bits BMP

 To intensify the Watermark effect, the Watermark image can perform binary and invert processing. For 

example, if a ruler image is taken as the Watermark, you should binarize the ruler first and then invert the 

calibration tails, as a result, the black tails changed into white and the white background changed into 

black. 

4.10  Video Marker Tool 

Control 

Dialog 

Function  Operating method:  Choose Setup>Video Overlay menu and click the Marker page

Initial Set  * The Marker overlaid on the video window can look like a real Cross in the eyepiece 
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4.11  Line Profile Tool 

Control 

Dialog 

Function  Operating method:  Choose Process>Line Profile menu

Initial Set 

 *Click the Line button on the toolbar to draw a Line, choosing Process>Line Profile menu will start the 

Line Profile dialog. The R,G and B values under the line will be plotted in the Image Line Profile 

window. It reflects the linear brightness color value distribution under the Line in real time. The Profile 

line will change according to the Line position or when the Line starts. 

4.12  Color Composition Tool 

Control 

Dialog 

Function 

 Operating method: Choose Process>Color Composite menu

 When and only when a gray image is available, the Color Composite menu will be enabled. Please 

change the captured image to gray when starting. 

Initial Set 

 *Choose the right color from the dye list according to the dye name and bring the gray image back 

to color. If the dye list does not have the required dye, define it with the right color first. 
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The Original 

Image 

Colorized 

by Pseudo 

Color 

Color 

Composited 

Image 

 During the Color Composite process, select the images, adjust 

their brightness (B), contrast ratio(C) and gamma value 

(G) separately. Make sure the size and content of the images 

fits. 
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5 Software Image Process Modules 

5.1 Filter  Shift+F 

Operating Method: Choose Process>Filter Menu. 

The software provides various kinds of filters through which you can acquire ideal images efficiently. 

Generally, the filters are divided into two categories: Convolution filters and Non-convolution (Morphological) 

filters.  

No matter what category the filter is in, different kernels take different effect on the filtered results despite the 

same filter category. The software also allows access to custom filter kernels. The filter dialog involves four 

property sheets or tabs, each of which has its own filter. With any filter you can view real-time effects in the 

preview window. Click OK or Apply, and the filtered results are always written to the active image. Clicking OK 

will close the dialog box while clicking Apply keeps the dialog box open. The Edit>Undo command will 

cancel any applied operations you are not satisfied with.

5.1.1 Filters: Image Enhance 

Shown as below, this property page includes filters as follows: 

Item Description 

Low Pass  The Low Pass filter replaces the center pixel with the mean value in its neighborhood. Checking this 

filter can soften the image and remove noise by eliminating high-frequency information (this has the 

effect of blurring sharp edges). 

High Pass  The High Pass filter enhances high-frequency information by replacing the center pixel with a 

convolved value calculated from a certain kernel. 

Gauss  Similar to Low Pass filters, Gauss filter can soften the image by eliminating high-frequency 

information. This filter is not as effective as the Low Pass. It softens image with its Gaussian formula. 
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High Gauss  Similar to the Sharpen filter, the High Gauss enhances detailed information of images, but with less 

noise and a Gaussian curve type of kernel. 

Equalization  The Equalization filter enhances image contrast based on the histogram algorithm. 

Sharpness  The Sharpness filter enhances detailed information of images. 

Median  The Median filter removes impulse noise from an image. It first sorts out the neighborhood 

pixels according to luminance value, then replaces the current pixel with the Median value. 

Rank  Similar to the Median filter, the Rank filter also removes impulse noise from an image. The 

pixels in the kernel are ranked by order of intensity, and the pixel in the range at the rank percentage 

is chosen for comparison. For example, in a 5x5 kernel, there are 25 pixels. A rank percentage 

of 95% would choose the second-brightest pixel for comparison. If the difference between the 

selected pixel and the center pixel is greater than the threshold value, the Rank filter replaces the 

value of the center pixel with the value of the selected pixel. 

The functions of filters are in relation to the factors below: 

For Image Enhance filters, the shape and size of kernel is very important. 

For Equalization filters, their options relate to histogram Equalizations, among them is Local 

Histogram Equalization which modifies the contrast of an image based on the pixel values in a small window 

surrounding each pixel.

Item Description 

3x3  Checking 3 x 3 kernel will produce a more subtle filtering effect. 

5x5  Checking 5 x 5 kernel will produce a moderate filtering effect. 

7x7  Checking 7 x 7 kernel will produce a more extreme filtering effect. 

Passes 

 The number of times a filter is applied on the image. Each operation is based on the results of the 

previous operation. So the more times a filter is applied, the more amplified the effect will be. 

Strength 

 The applied value reflecting how much of the filtering effect is on the image. The range is from 1 

to 10. A vaule of 10 specifies the full strength (100%) of the filtered result applied to each 

pixel. A value of 1 indicates that only 10% of the difference between the filtered pixel value and 

the original pixel value should be applied. 

Rank 

 This value specifies which pixel in the sorted array will be used to replace the center pixel. Pixels in 

the array will be sorted in ascending order. The pixels are indexed from 0 to Kernel Size x Kernel 

Size-1. The pixel index 0 corresponds to the lowest pixel value.

 The Rank will be specified in terms of a percentage of the indexes (Kernel Size x Kernel Size-1). 0%

rank means the lowest index (lowest gray value), 50% Rank means the middle of the array. and 100%

rank means the highest index (highest gray value) 
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The Equalization filter enhances image contrast based on the histogram algorithm, it has the following options. 

Item Description 

Local Histogram 

Equalization 

 Local Histogram Equalization equalizes an entire image or partial image according to the size of 

window. 

Window 

 Image pixel statistics (min, max, histogram, mean, standard deviation, etc.) will be calculated on a 

small Window of the image. These measurements are then used to derive the local contrast for that 

area of the image. In short, an area of Window x Window around each pixel is all that is considered 

when modifying the intensities in the image. A larger Window produces smoother results, while a 

small Window tracks small details more closely. 

Best Fit 

 Choose Best Fit command to optimize the values for the particular image. The results are achieved by 

stretching the local histogram to maximize the contrast between the brightest and darkest pixels in the 

local window region. 

Linear 

 This option distributes the histogram linearly across the intensity scale. This function produces a high 

contrast image with the highest possible dynamic range. 

Logarithmic 

 This option concentrates the histogram at the low end of the scale. This function produces a high 

contrast image with a small dynamic image. It will tend to darken the image overall. It is useful 

for increasing the contrast in a very light image. 

Exponential 

 This option concentrates the histogram at the high end of the scale. This function produces a high 

contrast image with  a small dynamic image. It will tend to lighten the image overall. It is useful 

for increasing the contrast in a very dark image. 

5.1.2 Filter: Edge Enhance 

Shown below, this property page includes filters as follows: 
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If one of the Edge filters (Laplace, Variance, Horizontal and Vertical Edge filters) has been checked, 

the options will relate to kernel size, passes, and filtering strength. The following options will be displayed:

Note: If you have selected Sobel, Phase or Roberts, no additional options are available.  If you have

selected Variance, the Passes and Strength options are not available.

5.1.3 Filters: Morphological 

Shown below, this property page includes filters as follows: 

Item Description 

Sobel 

 Check this filter to enhance the principal edges in an image. (The Sobel applies a mathematical

formula to a 3x3 neighborhood to locate and highlight its edges).

Roberts 

 Check this filter to enhance fine edges in an image. The Roberts filter is not a convolution filter. It

applies a mathematical formula upon a 4 x 4 neighborhood to produce its effect. The upper left pixel in

the neighborhood is the one that is replaced.

Sculpt  Check this filter to apply a sculpted effect on the image.

Laplace  Select this filter if you want to enhance all the edges in an image.

Variance 

 Select this filter if you want to detect and emphasize edges and textures. The Variance filter substitutes

a pixel with the standard deviation for its neighborhood.

Horizontal  Check this filter to detect and emphasize horizontal edges.

Vertical  Check this filter to detect and emphasize vertical edges.

Item Description 

3 x 3  Check 3x3 kernels to produce a more subtle filtering effect.

5 x 5  Check 5x5 kernels to produce a moderate filtering effect.

7 x 7  Check 7x7 kernels to produce a more extreme filtering effect.

Passes 

 Enter the number of times that the filter will be applied to the image. When a filter is applied multiple

times, its effect is amplified by each pass. An image that has been softened by one pass of the Image

Enhancement Filter, will be softened further by a second pass.

Strength 

 Enter a value from 1-10 that reflects how much of the filtering effect to apply to the image. A value of 10

specifies that the full strength (100%) of the filtered result will be applied to each pixel. Values less than

10 cut the full weight of the filter - a value of 1 indicates that only 10% of the difference between the

filtered pixel value and the original pixel value should be applied, a value of 2 indicates that 20% of the

difference should be applied, and so forth.
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Item Description 

Erode 

 Check this morphological filter to modify the size of objects in the image. The Erode filter erodes 

the edges of bright objects and enlarges the edges of dark ones. 

Dilate 

 Check this morphological filter to modify the size of objects in the image. The Dilation filter dilates 

bright objects and erodes dark ones. 

Open 

 Check this morphological filter to modify the shape of objects in the image. Assuming the image 

contains bright objects on a dark field, the Open filter will smooth object contours, separate narrowly 

connected objects, and remove small dark holes 

Close 

 Check this morphological filter to modify the shape of the objects in the image. Assuming the 

image contains bright objects on a dark field; the Close filter will fill gaps and enlarge protrusions to 

connect objects that are close together. 

Tophat 

 Check this filter to detect and emphasize points, or grains, that are brighter than the background. 

There are 3 kernel sizes for this processing. Click the radio button to change the kernel size to the 

value that most closely matches the size of the grains to detect. 

Well 

 Check this filter to detect and emphasize points, or grains, that are darker than the background. There 

are 3 kernel sizes for this processing. Click the radio button to change the kernel size to the value that 

most closely matches the size of the grains to detect. 

Gradient  Check this filter to enhance edges in an image. 

Watershed 

 Check this filter to separate objects that are touching. The Watershed filter erodes objects until they 

disappear, then dilates them again, but will not allow them to touch. The Watershed filter will not 

operate upon True Color images. To separate objects in a True Color image, first convert it to Gray 

Scale (see : Image>Gray Scale). 

Thinning 

 Check this filter to reduce an image to its skeleton. When choosing this filter, set the threshold 

that determines whether a pixel is part of the subject, or part of the background (see Options 
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If Erode, Dilate, Open, or Close filters are checked, the options will relate to the kernel size and shape. 

The following options will be presented: 

Item Description 

2 x 2  Check to use the 2x2 square kernel configurations. 

3 x 1 Row  Check to use the 3x1 row kernel configuration. 

1 x 3 Column  Check to use the 1x3 column kernel configuration. 

3 x 3 Cross  Check to use the 3x3 cross kernel configuration. 

5 x 5 Circle  Check to use the 5x5 circular kernel configurations. 

7 x 7 Circle  Check to use the 7x7 circular kernel configurations. This is a two-pass filter, accomplished using a 5 x 

5 circle followed by a 3x3 cross. 

11 x 11 Circle  Check to use the 11 x 11 circular kernel configurations. This is a three-pass filter, accomplished using 

a 5 x 5 circle followed by another 5 x 5 circle, followed by a 3 x 3 cross. 

Passes  Set the number of times to apply the filter. 

If the Tophat, Well, or Gradient filter is selected, the options will relate to kernel size and shape. The following 

options will be presented: 

Item Description 

3x3  Check to use the 3x3 square kernel configurations. 

5x5  Check to use the 5x5 square kernel configurations. 

7x7  Check to use the 7x7 square kernel configurations. 

If the Distance, Thinning, or Watershed filter is checked, the options will relate to the threshold. The 

following option will be presented: 

Item Description 

Threshold Enter a percentage value from 1-100 that specifies the intensity value to Threshold binarize the 

below). The Thinning filter will not operate upon True Color images. To thin a True Color 

image, first convert it to Gray Scale. 

Distance 

 The Distance filter is used to show the distances of pixels within blobs to the outer boundaries of 

those blobs. After applying the distance filter, the background will be black (i.e. pixels with value 0). 

Only the area within the blobs will have non-zero values (will be white). The values of each pixel 

within the blob will be a count of the shortest distance from that pixel to the edge of the blob. Thus, 

all pixels along the blob's border will have a value of 1 (since they are one pixel away from the edge 

of the blob); pixels that are a distance of 2 from the border will have the value 2, and so on. This 

creates a distance map of the image. The Distance filter will not operate upon True Color images. 

To use the Distance filter with a True Color image, first convert it to Gray Scale. 
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image. For example, a Threshold of 50% on a Gray Scale image would set all values ≤127 to 0 

(black) and all values ≥128 to the maximum value for that image class (white).

5.1.4 Filter: Kernel 

The Kernel page allows editing kernel files for both Convolution and Morphological filters. The dialog shows 

as below: 

Note: The HiPass, LoPass, Laplace and Unsharp kernel files are used by the HiPass, LoPass, Laplacian and 

Sharpen options listed in the Filter window (i.e., there is no difference between selecting one of these kernel files 

and selecting its option button in the Filter window -- the two methods ultimately do the same thing).  Because 

these kernel files are essential to the operation of these filtering options, they must not be deleted or renamed. 

Item Description 

Filter type  Check to modify the kernel for a selected Filter type, either Convolution or Morphological filters.

Edit 

 Name: This list box contains the name of the selected kernel file. To save the modified kernel file

to the same file, leave it as it is. To save the file to a new location, enter the new filename here.

 Kernel Size: Click the spin buttons or enter the number to change the size of the kernel. Either

direction may take into account one to nine pixels. As the Kernel Size is modified, the shape of the

kernel representation changes accordingly. In the center of the dialog, there are white boxes containing

coefficients that will be multiplied with each pixel that will be taken into account by the filter kernel.

It is possible to change any coefficient by clicking on it and adjust it as desired.

 Fill: Click this button to fill every element of the kernel with a particular value. The Fill kernel dialog

appears. Enter a value between 0 and 10. Using the Fill button is useful for setting all

coefficients to the same value. Change the coefficients that require a different value.

 Offset: The pixel value being modified is usually the center-most pixel. However, it is possible to

designate any pixel. The software signals the pixel to be changed by putting a box around it. Choose
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X and Y Offset spin buttons to apply.

New•••  Click to create a new filter kernel. The Edit Kernel dialog will appear. The functions of the dialog are

the same as the dialog for Edit••• described above), with the exception that the file name for the new

kernel file must be provided.

Delete  Click to Delete the selected filter kernel file.

5.2 Range••• Shift+R 

Operating method: Choose Process>Range menu 

The Range command provides the ability to set the intensity levels of the image to increase the contrast

and enhance the display in low-light situations. 

5.3 Segmentation••• Shift+S 

Operating method: Choose Process>Segmentation menu. 

Segmentation process is a Histogram based model for identifying certain colors in the segmented range. The 

segmented range can either be selected by two vertical bars with the mouse, or by directly editing the value

Item Description 

High & Low end  The Range dialog shows the Histogram of the current image on which two vertical marks stand for

high and low end of strength. The cursor can move the marks. While looking at a colorful

image, the Histogram will show red, green and blue colors with corresponding colored lines.

2 Edit Controls  The edit controls specify values of strength extreme. Clicking on the up or down arrow on the spin

button will increase or decrease the value. Those values from 0 to low end are black and the value

that ranges from high end to maximum on the scale are white.

Reset  The Reset button allows resetting the black and white levels to the high and low ends of the dynamic

Range. Reset only effects the displayed range, Reset all functions will display original settings.

Best Fit  The Best Fit button automatically sets the intensity levels to the Best Fit. It instructs the Software

to optimize the brightness and contrast values for the particular image.

Invert  The Invert button reverses the color of the image.

Update  Update will refresh the display Histogram of the current dialog.
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through the two edit controls. The colors used are specified by the system palette. For the 24 bit true color image, 

the Segmentation operation can be performed in either Red(R), Green(G), or Blue(B) channels separately. 

5.4 Binary•••  Shift+B 

Operating method: Choose Process>Binary menu. 

Binary is a kind of gray level process. If the gray of the pixel is greater than the given threshold, the pixel's 

color will be changed into white. Otherwise, it will be changed into black. After this process, the image turns out 

to be a dichromatic image with only black and white color. Although the process may lose some information, it 

is an indispensable step of some processes. 

The curve on the Binary dialog shows different gray levels of the image. The line in the dialog indicates the 

threshold value. To change the value, you can drag it to change the threshold, or change the number in the Edit 

control on the dialog.  

Click the Best Fit button to apply the auto threshold process to the image. The process offers an automatic 

threshold, clicking Best Fit can help make the image Binary. 

5.5 Emboss•••  Shift+E 
Operating method: Choose Process>Emboss menu 
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Emboss is a kind of artistic process which makes the image look like an empaistic image. The Preview 

button in the Emboss dialog will preview the image before creating it. The process supplies 3 kinds of 

convolutions including Gradient, Different, and Prewitt. There are 8 directions for each convolution method. Users 

can get different effects with different convolution methods or directions. 

5.6 Pseudo Color••• 
Operating method: Process>Pseudo Color menu. 

The image must be in Gray mode. Pseudo Color command colorizes the active monochromatic image to 

highlight certain features in a gray scale image. The command does not modify the pixels' values in image bitmap 

(it does not convert the image to true color or palette), but it creates a special palette with which the 

monochromatic image is displayed. It simply associates a Pseudo Color palette with the image that interprets the 

gray-level values in the image as color.  

To select the start and end colors of the range,  click the buttons at each end of the color strip separately to 

bring up the color dialogs. The set result displays at the middle gradient bar.  

5.7 Surface Plot••• 

Operating method: Choose Progress>Surface Plot••• menu. 
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This command tool reflects the image intensity values intuitively as 3-D. While in the 3-D coordinate, X 

axes represents length, Y axes represents width, Z axes represents brightness. The rendering effect can be 

achieved in the preview window, and image position can be drawn in the window by adjusting the mouse. 

Item Description 

3-D Preview

Window Direction 

 Setting the edit box on the left side can adjust the 3-D surface plot position in the preview 

window, the default value is -0.5.

 Setting the edit box on the right side can adjust the relative. The default value is 1. 

Image  

Background Color 

 Adjust the preview window Image Background Color by activating the Color dialog box 

system. 

Capture  Capture the active image in the viewpoint window as a new image. 

Color Table 

 Choose an appropriate color to display the different gray values in this table. Click the left color 

button to set the start color value, click the right color to set the end color value, the 

intermediate color bar displays the changes between the start point color and the end point (the 

relative information can be referred as color). 

Reset  Sets the Position Solid's two edit controls to their default values. 

5.8 Line Profile••• 

Operating method: Choose Process>Line Profile menu. 

This tool illustrates how pixels along a selected line are distributed by graphing the number of pixels at each 

color's intensity level. In a Line Profile, the X-axis represents the spatial scale, and the Y-axis represents 

the intensity values which range from 0 to 255. 

Item Description 

Background  Invoke the windows Color dialog to set the Background Color of the profile window.

Title  Use this command to set a Title on the Line Profile image. 
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Capture  Capture the image in the Line Profile window as a new untitled image.

Copy  Copy the Line Profile window's content onto the clipboard.

Save as  Save the Line Profile image in bmp format.

5.9 Diffuse•••Shift+D 

Operating method:  Choose Process>Diffuse menu. 

Diffuse is a kind of artistic process that can diffuse the image. Users can adjust the parameter in the dialog 

to control the degree of the diffusion. Value range: odd number between 1~30. 

Item Description 

Size  Illustrate the diffuse degree, default value:1 Range:1~29. 

Preview  Check it to display the real-time effect when dragging the slider bar. 

5.10  Granuate•••Shift+G 
Operating method: Choose Process>Granuate menu 

Granuate is a process that can make the image blur. User can change the degree of image blurring, the value 

range:1~20. 

Item Description 

Size  Illustrate the Granuate size, default value:1,Range:1~20

Preview  Check it to display the real-time effect when drag the slider bar
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